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INTRODUCTION – GETTING STARTED
AECOSIM BUILDING DESIGNER BASICS
AECOsim Building Designer is a shared, multiple-discipline Building Information Modeling
application that requires installation of only one application. AECOsim Building Designer is a
single product with licenses for Architectural, Structural, Mechanical, and Electrical, including a
fully integrated dataset and shared toolsets.

AECOsim Building Designer is specifically developed for architects, structural engineers,
electrical engineers, mechanical engineers, and other building professionals to design, analyze,
and construct buildings of all types and scales.
AECOsim Building Designer comprises a Unified Task Interface as well as streamlined
interoperability between disciplines allowing for shared design building objects. Any of the
specialized discipline toolsets can be operative at any time.
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The focus of this application enables designers and engineers to employ a strategy that
addresses various essential project life cycle needs, including:






Mass Modeling and Space Planning that occur in the beginning stages of a project.
Production oriented activities that occur during modeling such as placement of walls,
doors, and windows.
Drawing, scheduling, and reporting that occur throughout the life cycle of a project and
therafter.
Improved user –friendly operability provided by the unified task interface.
New Clash Detection capabilities that actively identify modeling interferences by
identifying them within the application earlier in the design process.

This Quick Start Guide introduces the user to AECOsim Building Designer by following a typical
project workflow beginning with Mass Modeling and Space Planning, developing the initial
geometry into a BIM model, and then creating drawings, schedules and reports. Concepts and
tools will be introduced as required for the workflow and organized by discipline.
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GETTING STARTED
AECOsim Building Designer can be launched from any one of five desktop icons. All icons will
start the same AECOsim Building Designer application; however, different tool sets will be
available depending on the icon selected.
STARTING ARCHITECTUR AL BUILDING DESIGNER
Choose the Architectural Building Designer icon from the desktop or the Start
menu [Start > All Programs > Bentley > AECOsim Building Designer V8i
(SELECTseries 3)] to start the application with the architectural tool set. Application
tools for Structural Building Designer, Mechanical Building Designer and Electrical
Building Designer can be launched from within Architectural Building Designer once
it is initiated.
Choose the Structural Building Designer icon from the desktop or the Start menu
[Start > All Programs > Bentley > AECOsim Building Designer V8i (SELECTseries 3)]
to start the application with the structural tool set. Application tools for
Architectural Building Designer, Mechanical Building Designer and Electrical Building
Designer can be launched from within Structural Building Designer once it is
initiated.
Choose the Mechanical Building Designer icon from the desktop or the Start
menu [Start > All Programs > Bentley > AECOsim Building Designer V8i
(SELECTseries 3)] to start the application with the Mechanical tool set. Application
tools for Architectural Building Designer, Structural Building Designer and Electrical
Building Designer can be launched from within Mechanical Building Designer once it
is initiated.
Choose the Electrical Building Designer icon from the desktop or the Start menu
[Start > All Programs > Bentley > AECOsim Building Designer V8i (SELECTseries 3)]
to start the application with the Electrical tool set. Application tools for Architectural
Building Designer, Structural Building Designer, and Mechanical Building Designer
can be launched from within Electrical Building Designer once it is initiated.

If AECOsim Building Designer is selected, all the Architectural, Structural,
Mechanical, and Electrical tools will be available simultaneously.
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Windows File Open Dialog Box
The Windows File Open dialog box is the first dialog box to appear when Building Designer is
selected. It is here the designer creates new model files or navigates through directories to
open existing files. Models reside in files called DGN (or Design) files which have the extension
*.dgn.

Designers begin working in pre-configured, integrated, multiple-discipline project workspaces
that can be saved on a local machine, a network drive, or managed by a Bentley ProjectWise
environment. The workspace stores information about the project such as the path for the
design file, reference files, cell or block libraries and configuration variables.
In the Workspace group box, located in the bottom, right hand corner of the Windows File
Open dialog box, the designer chooses the workspace by choosing a unique User, Project, and
Interface. The designer can choose from a drop-down list of different projects, which will
automatically set the directory path for all design project DGN files (the project dataset,
libraries, et cetera).
Building Designer is delivered with an example project, BuildingSample_US. The Windows
File Open dialog box will, by default, point to this folder when the software is launched for the
first time.
AECOsim Building Designer uses a MicroStation document file called a DGN file, with the
extension *.dgn. One or more models can be contained in a DGN file with each model having
its own set of views. There are three types of models: design models, drawing models, and
sheet models.
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Creating a New DGN File
New DGN files are created the same way in all Bentley Building applications. To create a new
DGN file, simply choose New from the File menu in the Windows File Open dialog box, which
will open the New dialog box.
New DGN files are created using appropriate seed files (seed files are DGN file templates),
which are used to specify the working units and the precision for a model file. Several seed
files are delivered with AECOsim Building Designer and designers can create additional seed
files for their own custom applications. The seed file designseed.dgn is generally used to
create new 3D DGN model files. The seed files drawingseed.dgn and sheetseed.dgn are
used to create 2D DGN files for drawing creation.
Opening a DGN File
DGN files are opened from the Windows File Open dialog box. When a DGN file is selected, a
thumbnail of the file displays in the preview window, located on the right side of the dialog
box. When the designer opens a DGN file and another file is open, Building Designer
automatically closes the first file prior to opening the second.
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THE INTERFACE
The AECOsim Building Designer interface is devised to provide flexibility in arranging
workspaces for a given task or group of tasks. Specific sets of workflow task commands and
tool frames interface to facilitate this organization for each discipline.
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View Windows
A total of eight view windows are available for each model file to assist in viewing designs from
various perspectives. Top/plan, front elevation, right and left elevations, isometric, bottom,
back, or other combinations are available.

Each view window can be opened, resized, relocated, or closed to make room in the design
interface. All eight view windows, or any combination of views, can be opened at any time and
view window layouts can be saved in specifically defined view groups. Saving a view in this
manner will save only the view attributes. All model elements in the view are “live” and will be
updated with changes as the model changes.

View Group Menu showing the active View Group Design Model with View 1,2, and 3 displayed on and 4, 5,
6, 7, and 8 displayed off.

To save View Window size and layout, select File>Save Settings, or <Ctrl F>.
With a two screen system, two application windows can be opened. Go to the pull down
Workspace>Preferences>Operation and select Open Two Applications Windows.
Saved Views can recall a View Windows Aspect Ratio, Size, or Size and position.
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View Controls
View controls can manipulate a view, specifically the portion of the design that is displayed in
the view window. View controls are located in the View Control Bar, which is part of the
horizontal window scroll bar, found in the upper left view window border.

View Attributes
The View Attributes Dialog box is in located in the View Control Bar.
by the shortcut key-in <Ctrl B>.

It can also be accessed

The View Attributes dialog box allows control of
whether and how certain types and classes of
elements are displayed and whether certain
drawing and modeling aids are displayed.
Different display attributes can be applied to
different Views.
Changes to the selected view take effect
immediately.
If Apply To Open Views is enabled,
changes are applied to all open views.
By default, all of the 2D Symbols of Building
elements such as Doors, Windows, etc., are
found under the Construction Class type. To
display only the 3D elements in the model,
turn the Constructions attributes off.
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Task Interfaces
Task Interfaces help designers select and create a method
of workflow that facilitates maximum productivity. The
interfaces support designers by making portions of each
application readily and easily available in one place. For
example, in a task interface, an assortment of commonly
used tools and commands for many different modeling
operations are simultaneously available in one location. So
instead of selecting tools from several menus and tool boxes
to complete a series of related tasks, designers can
navigate to one location to use the same commands for all
design needs.
Task groups within a selected task interface are often varied
depending on the application. Architectural task groups can
include groupings of tools for modeling and schematic
design, while other tool groups are included for general
tasks such as drafting, annotation, and reporting.
Notice that the Architectural Building Designer task menu
has shared tools available such as Structural and HVAC
modeling tools.
To access the additional tools for Structural, HVAC, or
Electrical, while running the Architectural tool set, go to the
Building Designer pull down and load the other applications.

By selecting the Load Space Planner, Load Structural, Load
Mechanical, or Load Electrical there are additional modeling
tools and Structural Import/Export capabilities quickly
incorporated.

There are three layout modes available for the task interface: Icon layout mode, List
layout mode, and Panel layout mode.
www.Bentley.com/AECOsim
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Task Interface Tool Help
Users can right-click tool help within the Task Based Interface to learn more about a command
or function.
A right click on an application tool in the task based
interface opens a pop-up menu where an option for
help is located at the bottom of the menu. Designers
can navigate here obtain additional help for application
tools. The task interface displayed here is shown in
panel layout mode. When the pop-up menu's Display
Help option is chosen, the online Bentley Building Help
window opens and the help page for the selected tool
displays.

Bentley Building Help
Bentley products offer extensive online Help systems.
The Help window is divided into two frames. The left frame contains the Table of Contents and
displays all the available help topics. The right frame is the document body frame and displays
the text associated with the currently selected topic.
Hypertext links appear in color (blue) throughout the online help system, and will be
underlined when the cursor touches them. The links help the designer move rapidly between
related help topics. Designers can browse help topics and search the help data base for items
in the help and individual help articles that can be printed.
An optional Help Tracking feature is also available from the Help menu. When enabled, this
Help feature automatically displays Help for each tool as it’s selected Another option, entitled
“Tool Tips” is available from the Help menu. When this option is on, a tool tip (yellow rectangle
with text displaying the name of the tool) appears when the pointer is positioned over any tool
icon within the interface.
When the Use It tool icon is selected in the Help window, the help session is transported back
to the model file where that tool is active and ready for use with focus in the tool settings
window or settings dialog box.
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ACCUDRAW
AccuDraw is a design aid that assists designers with parameters such as the current pointer
location, the previously entered data point, the last coordinate directive, the current tool's
needs, and any directive that has been entered with keyboard shortcuts or AccuDraw options.
AccuDraw then generates the appropriate precision coordinates and applies them to the active
tool. AccuDraw is an essential aid for 3D modeling, as well as 2D drafting.
The AccuDraw Compass
The most notable AccuDraw feature is the compass. Only visible when AccuDraw is active (by
selecting the AccuDraw tool icon from the Primary Tools tool box), the compass has control of
the coordinate input and acts as both a status indicator and a focus for input. The center of the
compass, called the origin, is the focal point of all AccuDraw operations. All AccuDraw
directives act in conjunction with the compass.
Surrounding the origin is the drawing plane indicator. Its primary purpose is
to show the current orientation of AccuDraw's drawing
plane and the active coordinate system. When the plane
appears as a dashed rectangle, the Rectangular
Coordinate System (X, Y, Z) is active. When the plane
appears as a dashed circle, the Polar Coordinate
Rectangular
System (Distance, Angle) is active.
Coordinate
Mode

Polar
Coordinate
Mode

The keyboard shortcut to toggle between
rectangular and polar modes is <spacebar>.
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Rotating the Drawing Plane
Generally, 3D Models seem much easier to visualize while they are worked on in 3D pictorial
views or isometric (iso) views, for example. The AccuDraw compass rotates to set the 3D
drawing plane so that elements placed in pictorial views add just as quickly and easily as when
placed in 2D orthogonal views. AccuDraw automatically constrains data (entry) points to the
drawing plane, regardless of the active view orientation, to make this possible.

<T> Top Rotation

<S> Side Rotation

<F> Front Rotation

The AccuDraw compass rotates using a series of keyboard shortcuts (<F>, <S>, <T>) to align
the axes of the compass with the drawing plane (Front, Side, Top) and to proceed in the
desired direction (negative or positive X, Y, Z). So the designer can place elements in 3D space
while drawing on a plane that is oriented to any orthogonal (or auxiliary) view. Floors can be
placed to be truly horizontal, walls can be situated to be truly vertical, and a roof can be
arranged on a slope angle that is truly accurate.
The AccuDraw Window
AccuDraw has its own window called the AccuDraw window. This small
window contains data entry fields and axis lock check boxes for the
current active coordinate system. When the AccuDraw window opens, it
is floating just like any other window. It can be docked to the top or
bottom edge of the view window to minimize its' intrusion into the
design area.
Rectangular Coordinate
mode

The keyboard shortcut to toggle between the data entry fields is
<tab>.

Polar Coordinate mode
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ACCUDRAW SHORTCUT KE Y-INS
There are a number of shortcut key-ins that can be used in conjunction with AccuDraw.
Shortcut
Keys
What Does it Do?
AccuDraw distances/locks
Space
Swaps between XY and Distance angle
Enter
Smart Lock - Locks the active drawing axis
A
Locks the angle in the distance/angle AccuDraw dialog
D
Locks the distance setting in the distance/angle AccuDraw dialog
X
Toggles the lock status for the X value
Y
Toggles the lock status for the Y value
Z
Toggles the lock status for the Z value (3D only)
LI
Locks AccuDraw’s current index
O
Relocates the compass origin to the cursor position
AccuDraw Compass Rotation
F
Rotates the compass to front view orientation
S
Rotate AccuDraw cursor to side orientation
T
Rotate AccuDraw cursor to top orientation
V
Rotate the AccuDraw cursor to match the view orientation
Cycles the compass rotation through top, front and side orientations in 3D
E
(Responds to ACS Plane Lock)
RC
Rotate the AccuDraw cursor to match the active ACS plane
RE
Rotate the AccuDraw cursor to match the Selected Element
RQ
Rotate the AccuDraw cursor dynamically by selecting a point
RX
Rotates the compass 90 degrees around the X axis (used in 3D)
RY
Rotates the compass 90 degrees around the Y axis (used in 3D)
RZ
Rotates the compass 90 degrees around the z axis
B
Rotates the AccuDraw compass to match last angle placed
Modify the Drawing's Auxiliary Coordinate System
GA
Retrieves a saved Auxiliary Coordinate System
RA
Rotates the active Auxiliary Coordinate System
WA
Save the active Auxiliary Coordinate System
LP
Toggle ACS Plane and Plane Snap Lock
LA
Toggle ACS Plane Lock
LS
Toggle ACS Plane Snap Lock
LZ
Toggle Sticky Z Lock
AccuDraw Settings
Q
Closes AccuDraw
GS
Opens the settings box for AccuDraw
HA
Put AccuDraw on Hold
?
Shows the AccuDraw shortcut list
Give AccuDraw Focus
f11
Give AccuDraw Focus
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Mechanical Component Placement
Opens the Manufacturer Catalog dialog. (A catalog name must first be entered in
HC
Datagroup Info dialog)
RR
Reorients the fitting by toggling through the connect point
RW
Rotates the component 90° to the left about the AccuDraw X axis
RT
Rotates the component 90° to the right about the AccuDraw X axis
RD
Swaps the dimensional sizes for the placement end of the component.
RF
Swaps the dimensional sizes for all ends of the component
During component placement, sets the AccuDraw compass to the connected end
RO
of a component if dynamically connected
During component placement, sets the AccuDraw compass to the connected end
of a component if dynamically connected. If the connected end shape is
RP
"Round", the AccuDraw compass is adjusted to match the component's placed
orientation.
Sets the component into inline dynamic placement mode after an end connection
RI
is established. (The parent duct/pipe is broken to accommodate the inline
component.)
Mechanical Component Modification
Resizes connected components to reflect size changes during a component
RS
modification.
Advances the focus to the next connection on a component or to the next
R1 - R8
component for modification
Change Active Snap/Locks
C
Makes Center snap your active snap
I
Makes Intersect snap your active snap
K
Opens the keypoint snap divisor dialog
N
Makes Nearest your active snap
HS
Toggle Accusnap On/Off
HU
Suspend AccuSnap until after next data point
Entering Coordinates
P
Opens the point keyin (single)
M
Opens the point keyin (Multi)
Controlling Views
RV
Rotates active view to match AccuDraw cursor plane
Control other parts of Microstation
GT
Send Focus to the Tools Settings Window
GK
Open Keyin window
~
Scrolls through the 1st setting on the tool settings window in selected tools
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MOUSE FUNCTIONS
Before working in Building Designer, the designer needs to understand the functions of the
mouse buttons. In addition to controlling the cursor position, there are several button functions
that control data entry.
On a three-button mouse, the default button functions are:
•To Select an item — press the left mouse button.
•To Enter — press the left mouse button.
•To Accept — press the left mouse button.
•To Reset — press the right mouse button.
•To Enter a Tentative Snap Point — press the left and right mouse buttons
simultaneously.
Also, designers are occasionally exposed to on screen instructions that refer to mouse button
operations. For example, an instruction to enter a data point to place an element requires the
designer to press the left mouse button. An instruction to reset to stop the placement of an
element requires the designer to press the right mouse button.
The settings for mouse button functions can be changed by choosing Button Assignments
from the Workspace menu.
Snapping to Elements
Tentative snap points are used when precise data point entry is required. Snapping a tentative
point is the action that precisely defines the position of a new design element, in relation to
existing design elements in the model. With a tentative snap, the location of the next data
point can be previewed and defined before committing to the selected location.
To snap to a tentative point, move the pointer to the location (on an existing element) where
the new element will be constructed and press the mouse button(s) assigned to invoke
snapping. The existing element will highlight and a pointer crosshair appears at the tentative
point location. Use a Data point to accept the tentative snap point and resume modeling.
When multiple elements pass through a snap area, it is possible to snap a tentative point to
the wrong element. If this occurs, snap again until the correct element highlights. This is
referred to as cycling through the elements until the correct object is highlighted.
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Access to Snaps
The active snap mode is indicated by the snap mode icon located in the
right-hand portion of the status bar, at the bottom of the view window.
Select the snap mode icon to display the snap pop-up menu.
In order to open the Snap Mode button bar, select Button Bar from the
top of the Snap mode pop-up menu. Different snap modes may be selected
from the button bar, which can be docked at the bottom edge of the view
window.

The Snap Mode button bar. The icons are (from left to right): Toggle AccuSnap,
Nearest Snap, Key Point Snap, Midpoint Snap, Center Snap, Origin snap, Bisector
Snap, Intersection Snap, Tangent Snap, Perpendicular Snap, and Multi Snap.
Keypoint is the active snap

Key point, Intersection, and Center are three of the more commonly
used snap modes.
Key point is the default snap mode. When this mode is active, tentative points can be snapped
to key points on an element. For example, the exact end point of an element would be one
such key point.
A snap mode button is highlighted with gray when it is the active snap. To override the active
snap mode for a one single snap, select another snap button in the snap mode button bar. The
override is effective only for the very next operation and is cancelled upon the next snap.
To set a different snap mode as the default snap mode, double-click the snap icon to make
that snap mode the default.
AccuSnap
AccuSnap provides graphical assistance as a smart pointer for snapping to elements. It
automates the tentative snap process which can be used standalone, eliminating the need to
press the tentative snap mouse button(s).
When AccuSnap is active and a tool is selected, the designer moves the pointer over existing
elements to find and display (with a crosshair called the tentative hint) the closest tentative
snap points. When the correct snap point is displayed and the element highlights, the designer
enters a data point to accept and execute the active tool command at that location.
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Highlighted element with AccuSnap tentative hint, snap mode icon, and snap tip.

AccuSnap compliments the standard method of placing
tentative points. That is, the designer can continue to use
the standard tentative snap method (pressing the
tentative snap mouse buttons) with AccuSnap enabled.
However, in areas of high density and when placing
elements that are extremely close in proximity, it may be
advantageous to snap to points using the tentative snap
mouse buttons. AccuSnap can be readily turned off to
accommodate these types of situations.
AccuSnap automatically identifies elements (when they
are pointed to) in the pop-up snap tip (the tip can also be
turned off). This highly productive feature assists the
designer in determining the intent of the active tool and
whether or not the element can accept the operation for
the command. If the element is rejected from the
operation, a universal No symbol and a reason for the
failure will display in the snap tip.

Element with AccuSnap universal No symbol and snap tip.

ELEMENT SELECTION
Designers often want to create a selection of specific
sets of elements in order to modify and manipulate
them. A selection set can include as few as one, or an
unlimited number of design elements. Elements are
selected individually, or from within a group, or as
part of a group, or as a group, to conduct these kinds
of operations.
Several tools are available as part of the element
selection utility. The Element Selection tool is used
to manually select elements and create element selection sets. The Select by Attributes
option is used to create a selection set from common attributes such as level, color, family,
part, etc.
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